Author Topic: Possibly bug?  (Read 4267 times)

topmo3

  • Helper
  • Shoot
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 23
Possibly bug?
« on: December 21, 2008, 05:43:08 PM »
May be it is a bug, may be my fall:
when i change level4.level file and tried to increase AI factions:

<dir name="GAME">
    <dir name="ENEMYFACTIONSMIN" type="int" value="12" />
    <dir name="ENEMYFACTIONSMAX" type="int" value="12" />

then while playing all OK, until i discover next (not first) asteroid, possible occupied by AI
and Dyson throw exception
Exception "Index was outside the bounds of the array." in method
ProcGenGame.ColonyGame::GetFactionColour(int32 Owner, int32 colour)

Of course, this is can be from my wrong interpretation of parameters names.

Alex

  • Administrator
  • Ent
  • *****
  • Thank You
  • -Given: 3
  • -Receive: 15
  • Posts: 1,035
Re: Possibly bug?
« Reply #1 on: December 23, 2008, 04:57:24 PM »
Hi topmo,

You're completely right about the parameter, but there is a limit on the number of ai factions there can be - right now i am pretty sure it is ten. If you add more lines of colour to the file teams.png, you may find that works. Right now there are only colours used for team differences, so with more than around this number it starts to get hard to tell who is who when zoomed out.

Hope that helps!

topmo3

  • Helper
  • Shoot
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 23
Re: Possibly bug?
« Reply #2 on: December 23, 2008, 06:38:55 PM »
Thanx, Alex, for explanation.
I hope, you will defend the game from our unconscientious tries to change parameters in every file :)