Author Topic: Can't get Linux version to run.  (Read 4323 times)

0 Members and 1 Guest are viewing this topic.

cwr576

  • Seed
  • *
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 4
Can't get Linux version to run.
« on: November 16, 2012, 11:40:05 PM »
I'm trying to run the Linux version of Eufloria I got from the Humble Bundle.  I've installed it.  It core dumps when I try to run it.  What do I do now?

Anybody have sucess with this?  I'm running Fedora 17, 32 bit.

-- Charles

duobox:/usr/local/games/EufloriaHD$  ./EufloriaHD.bin.x86
Memory tracker offline.

Initialising System.

2012-11-16 09:13:23
Initialising Renderer.

Initialising Input.

Initialising Sound.

Initialisation successful.

Eufloria is initialising.

Initialize Lua

Loading font...

Font loaded.

Segmentation fault (core dumped)

sillytuna

  • Eufloria lacky
  • Administrator
  • Arboreal Being
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 92
  • Posts: 446
    • TunaHQ
  • Eufloria: Yes
Re: Can't get Linux version to run.
« Reply #1 on: November 17, 2012, 12:00:13 AM »
I've notified the bundle guys who handled the port. As soon as I have any answer I'll let you know.

sillytuna

  • Eufloria lacky
  • Administrator
  • Arboreal Being
  • *****
  • Thank You
  • -Given: 58
  • -Receive: 92
  • Posts: 446
    • TunaHQ
  • Eufloria: Yes
Re: Can't get Linux version to run.
« Reply #2 on: November 17, 2012, 12:34:21 AM »
Can you do the following and post the results:

  • document your distribution version and architecture
  • output of glxinfo  (specifically the direct rendering line and any opengl line)
Code: [Select]
glxinfo | grep -e direct\ rendering -e OpenGL

    cwr576

    • Seed
    • *
    • Thank You
    • -Given: 0
    • -Receive: 2
    • Posts: 4
    Re: Can't get Linux version to run.
    « Reply #3 on: November 17, 2012, 09:06:53 AM »
    Fedora 17, running on Intel Core 2 Duo, 32 bit.  Graphics: Gallium 0.4 on NV4B.

    glxinfo output

    direct rendering: Yes
    OpenGL vendor string: nouveau
    OpenGL renderer string: Gallium 0.4 on NV4B
    OpenGL version string: 2.1 Mesa 8.0.3
    OpenGL shading language version string: 1.20
    OpenGL extensions:

    Thanks:


    sillytuna

    • Eufloria lacky
    • Administrator
    • Arboreal Being
    • *****
    • Thank You
    • -Given: 58
    • -Receive: 92
    • Posts: 446
      • TunaHQ
    • Eufloria: Yes
    Can't get Linux version to run.
    « Reply #4 on: November 19, 2012, 05:39:12 AM »
    From our mr Linux - let me know how you get on:

    For the F17 issue, he's running an nvidia card using the nouveau drivers (the open source nvidia drivers).  Which are currently still in heavy development and do not support everything.

    http://nouveau.freedesktop.org/wiki/FeatureMatrix  (their's si the NV40 category, most likely a GeForce 7300). Installing the binary nvidia drivers from rpmfusion.org will solve the problem.

    cwr576

    • Seed
    • *
    • Thank You
    • -Given: 0
    • -Receive: 2
    • Posts: 4
    Re: Can't get Linux version to run.
    « Reply #5 on: November 19, 2012, 06:37:21 AM »
    I replaced the driver.  Eufloria is still failing to load, in exactly the same way as before.    No change.

    Here is the new glxinfo output:

    direct rendering: Yes
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce 7600 GT/PCIe/SSE2
    OpenGL version string: 2.1.2 NVIDIA 304.60
    OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
    OpenGL extensions:

    cwr576

    • Seed
    • *
    • Thank You
    • -Given: 0
    • -Receive: 2
    • Posts: 4
    Re: Can't get Linux version to run.
    « Reply #6 on: November 19, 2012, 07:43:40 AM »
    Investigating further, I discovered that the original install of Eufloria must have failed somehow (though I know it claimed it was sucessful).  There were only four files in /usr/local/games/EufloriaHD, one of which was the game binary I was running, but there was nothing in /usr/local/games/Eufloria/lib . 

    I reinstalled Eufloria, and it seems to be good now.  Thanks for your help   8)

    Thanks:


    sillytuna

    • Eufloria lacky
    • Administrator
    • Arboreal Being
    • *****
    • Thank You
    • -Given: 58
    • -Receive: 92
    • Posts: 446
      • TunaHQ
    • Eufloria: Yes
    Re: Can't get Linux version to run.
    « Reply #7 on: November 19, 2012, 07:56:25 AM »
    Glad you got it to work. I've passed the failed installer problem on.